Benutzer-Werkzeuge

Webseiten-Werkzeuge


freifunk:nodewithipv4

Node-Zugang aus dem Freifunk-Netz einrichten

Damit der Router aus dem Freifunk-Netz per IPv4 erreichbar ist muss an der Konfiguration /etc/config/network Änderungen vorgenommen werden. Dazu ist eine Root-Login notwendig.

WARNING!!!

Da die Router per IPv4/IPv6 erreichbar sind, muss ein sicheres Passwort vergeben werden, da über den Zugriff per SSH der Router beliebig konfiguriert werden kann und im theoretischen Fall ein Zugriff auf das lokale Netz, an dem der Freifunk-Router angeschlossen ist, ermöglicht werden kann!!!

WARNING!!!

IPv6 Zugang geht - sofern Root PW oder Key gesetzt immer, da gibt es manchmal konfusionen welches Interface jetzt welches andere erreichen will

einmalig auf der Rootshell IPv4 holen

einmalig auf der Rootshell IPv4 holen, zum Beispiel für den Paketmanager von OpenWRT um die Weboberfläche nachzuinstallien. Nach einem Reboot wäre diese wieder weg.

# auf der Routershell
udhcpc -i br-client -q 

Dynamische IPv4 Adresse

Es muss in der /etc/config/network der Eintrag für client folgendermaßen angepasst werden:

config interface 'client'          
        option reqprefix 'no'      
        option ifname 'eth0 bat0'  
        option proto 'dhcp'        
        option defaultroute '0'  
        option type 'bridge'     
        option macaddr '$MAC_FROM_INTERFACE$'   <- leave it as it is
        option peerdns '1'   

Damit der Router weiterhin auch eine IPv6 Adresse erhält muss noch folgender Eintrag hinzugefügt werden:

config interface 'client6'                
        option proto 'dhcpv6'
        option ifname 'br-client'
        option peerdns '0'       
        option ip6table '1'    

Statische IPv4 Adresse

Dazu bitte als erstes in der Tabelle für statische IPv4-Adressen eine neue IP registrieren.

Anschließend muss in der /etc/config/network der Eintrag für client folgendermaßen angepasst werden:

config interface 'client'          
        option reqprefix 'no'      
        option ifname 'eth0 bat0'  
        option proto 'static'
        option ipaddr '$IP_FROM_IPTABLE$'      <- as you registered
        option netmask '255.255.192.0'
        option broadcast '10.60.63.255'
        option gateway '10.60.0.100'
        option dns '10.60.0.100'
        option dns_search 'fffr' 	
        option type 'bridge'     
        option macaddr '$MAC_FROM_INTERFACE$'   <- leave it as it is

Damit der Router weiterhin auch eine IPv6 Adresse erhält muss noch folgender Eintrag hinzugefügt werden:

config interface 'client6'                
        option proto 'dhcpv6'
        option ifname 'br-client'
        option peerdns '0'       
        option ip6table '1'    

schnell wechselnde IPv4

Bisher war nur beschrieben wir man den Router dann anhand seiner IPv4 m Freifunk Netz erreichen kann. Allerdings ist die Leasetime des DHCP auf 10 Minuten runtergesetzt worden, das führt zu regelmässig neu vergebenen IPv4 Adressen, das finden des eig. Routers wird damit nicht leichter. Wer eine smarte Lösung hat kann sie hier rein schreiben.

trick 17 - alfred

man könnte einen Crontab einrichten und den wesentlichen aktuellen Teil der ifconfig über alfred rausposaunen. Den können dann natürlich ALLE in dem Layer2 Netz, also FreifunkFreiburg sehen. Bsp.code

crontab -e
#dort eintragen
*/5 * * * * (echo -n "this is my node " && uci get system.@system[0].hostname && ifconfig |head|tail -n1|sed -e 's/^[ \t]*//') | alfred -s 119

danach könnt ihr im batman Netz über

 alfred -r 119 

im Prinziep alles bekommen was so mit dem Identifier 119 getackt ist .. Probebetrieb hier ergab:

{ "c4:6e:f1:39:08:20", "this is my node freifunk-rauberhaus\x0a          inet addr:10.60.2.96  Bcast:10.60.15.255  Mask:255.255.240.0\x0a" },
{ "c4:6e:1f:d2:d4:ee", "this is my node fuzzle-wanderer\x0a          inet addr:10.60.14.61  Bcast:10.60.15.255  Mask:255.255.240.0\x0a" },

allg. Erreichbarkeit aus dem Internet

Da alle Clients und Nodes hinter VPN Gateways sind ist ein erreichen aus dem Internet schwierig. Eine Lösung wäre einen Gatewayserver aufzusetzen der dann bestimmte services „durchleitet“ und so einen Teil des Freifunknetzes direkt von aussen zugänglich macht, bzw. einen Teil des Internets direkt in das Freiburger Freifunknetz holen kann.

freifunk/nodewithipv4.txt · Zuletzt geändert: 2016/09/26 23:38 von viisauksena